Jump to content
The Twitter Feeds are now back on the Platform ×
  • 0

Unable to deposit money via Credit/Debit



Hi Team,

Anytime I try do a deposit via Credit/Debit card it just doesn't load? I tried via Edge which also has the same result where the page doesn't load?

When I try from the app I get an error "We have been unable to process your request. Please contact customer services" but when I do contact customer service it advises me that it's closed. 

I can do PayPal option as it loads fine but I really don't fancy having to spend the extra fee and waiting for the payment to come through. Any help will be appreciated!



Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • General Statistics

    • Total Topics
    • Total Posts
    • Total Members
    • Most Online
      10/06/21 10:53

    Newest Member
    Joined 30/03/23 17:41
  • Posts

  • Create New...