Jump to content
  • 0

MT4 Demo account issues


MAKTRADER6970

Question

Hi

 

I have IG MT4 downloaded and installed on my Windows 10 laptop.
I tried to open a demo account via file->open account -> selecting IG-DEMO trading server and then new demo account. At this point , after clicking next button (which greys out) nothing happens and gave up after waiting over 2 hrs.
 
What is going on please and why is it not letting me create a MT4 demo account?
 
Thank you
Link to post

8 answers to this question

Recommended Posts

  • 0
14 minutes ago, MAKTRADER6970 said:

Hi

 

I have IG MT4 downloaded and installed on my Windows 10 laptop.
I tried to open a demo account via file->open account -> selecting IG-DEMO trading server and then new demo account. At this point , after clicking next button (which greys out) nothing happens and gave up after waiting over 2 hrs.
 
What is going on please and why is it not letting me create a MT4 demo account?
 
Thank you

Hi, did you also open a mt4 account with IG from your My IG > add an account? You don't need to fund it but think you need it to receive the data feeds.

Link to post
  • 0
2 minutes ago, MAKTRADER6970 said:

Hi,

Yes I did but it didnt send me an email with password credentials.

I could try again but how do I delete the demo account I created on IG Index  first ?

Thanks

I'm thinking now it should work on just demo. To delete a demo open the navigator panel and Accounts should show at the top, just right click on the demo account and click delete.

Go back to File > Open an account, highlight demo > next > new account > next > and follow steps but make sure you check the 'agree to receive newsletter' box, nothing is sent but need to be checked  anyhow.

see if that works.

Link to post
  • 0

Hi again

When I go to my IG platform via browser and naviagate to "MY IG" I can see my MT4 account but there is no option to delete it - am I looking in right place?

Regards MT4 platform itself - it doesnt even go as far as allowing my tick the subscription - afte clicking 'next'  after ticking demo account type from 'Select account type'  it just sits there.

I did notice that IG-DEMO server does not ping - I'm assuming that is correct?

 

thanks

Link to post
  • 0
3 minutes ago, MAKTRADER6970 said:

Hi again

When I go to my IG platform via browser and naviagate to "MY IG" I can see my MT4 account but there is no option to delete it - am I looking in right place?

Regards MT4 platform itself - it doesnt even go as far as allowing my tick the subscription - afte clicking 'next'  after ticking demo account type from 'Select account type'  it just sits there.

I did notice that IG-DEMO server does not ping - I'm assuming that is correct?

 

thanks

sorry no, delete on the mt4 platform but just seen the delete option is only for multiple demo accounts, (pic 1)

and yes the scan for demo should return ping and highlight when clicked . (pic 2) if yours isn't > 

Check your server connection bottom right corner of mt4 screen, click on box and rescan (pic 3)

 

image.png.f72d4c2e378673000150887b84014dfd.png

 

image.png.8fe5be45f2db42ac9fe0c996e220c684.png

 

image.png.f1e5a841027f8dab34ef39b569df39e7.png 

                                                 ^^^^^

 

.

 

  • Like 1
Link to post
  • 0

Hi

Thank you for your detailed response - greatly appreciated.

All a mystery as I have tried pinging the IG-DEMO server number of times via scan without success plus IG-LIVE is not shown in the list. I tried another version of MT4 ( from different broker) p and that worked fine - so not a firewall issue. Totally confused.

 

If you have any further suggestions it would be greatly appreciated.

 

Thank you again

Link to post
  • 0
1 hour ago, MAKTRADER6970 said:

Hi

Thank you for your detailed response - greatly appreciated.

All a mystery as I have tried pinging the IG-DEMO server number of times via scan without success plus IG-LIVE is not shown in the list. I tried another version of MT4 ( from different broker) p and that worked fine - so not a firewall issue. Totally confused.

 

If you have any further suggestions it would be greatly appreciated.

 

Thank you again

no problem, maybe a corrupted file somewhere, probably worth just doing a reinstall.

Uninstall mt4 from computer's control panel > programs

and reinstall from the copy in your downloads folder.

It's the 'ig4setup' file - just double click.

Link to post
  • 0

Hi

I finally managed to resolve it - rather than use IG-LIVE I used the server name directly and that seemed to work. I then unfortunately got invalid database header errors which I resolved by rebuilding the charts.

 

Thank you again for all your help

Link to post

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...