Jump to content
  • 0

Active trade not responding to amendment commands and unable to close on FTSE and Germany 30.... regular problem!


BEVENSARAH

Question

Hi I really hope someone can answer this as it's a long term problem with IG chart trading.  This has happened to me on demo and active accounts.  When in a trade the system refuses to let me edit the active trade to change TP, SL or close.  This means that you can get stopped out when you would have chosen to manually close the trade before hand.  Really annoying and I wonder what IG have to say about it.  The last time this happened was on my demo account so not a disaster BUT what is IG's stance if this occurs on a live account?  I tried ringing them when the trade was still in profit but all their lines were saying the same thing.... "we're really busy...."!  I bet you are if this is also happening to others.  Glad to understand what action IG are taking to de-bug this issue from their otherwise brilliant platform.  I have uploaded a screengrab of the trade in question which shows it in loss to the tune of £48,000 and no way to close it!  Very annoying.  I logged out of my Edge browser and opened the platform on Apple but still not responding.

image.png

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...