Jump to content
  • 0

Firefox 70 logs in but won't open platform

Question

Hi

I've always used Firefox browser to open my trading platform but today for some reason it is not working. I can log on with my credentials to the 'My IG' page, but when I press 'open platform' it circles back to the 'My IG' page. The funny thing this is only happening on my new laptop, I have another laptop (same OS, browser etc) and it works fine on that.

I have tried reinstalling the browser, clearing my cache and history, I have even tried dns flush though the command prompt, but still firefox fails to open the platform. Has anyone else had this problem? Is there a fix anybody can suggest?

Thanks

Share this post


Link to post

1 answer to this question

Recommended Posts

  • 0

I had this problem when I used any other browser instead of Chrome. So now I stick to Chrome.

Edited by Ilana
Spelling
  • Like 1

Share this post


Link to post

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
You are posting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×