Jump to content
  • 0
Sign in to follow this  

Profit and Loss Trading Statements

Question

Please can we have an update on rectifying the problems with the P&L history statements. This problem has persisted for about 10 days now and was apparently being investigated as a priority by the incident team!

 

Positions closed earlier than 18th September cannot be seen.

The funding for closed positions is incorrect.

The closing total for each position is incorrect.

The funding still increases each day, despite the fact that positions have been closed some time ago!!

 

Accurate P&L accounts are a fundamental requirement. I simply cannot trust the data being presented on the screen at the moment.

 

This is very poor customer service by IG.

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

Its getting worse. Its two months since your mention of the history P/L issues and is now a lot worse.

Today's figures are a meaningless jumble of random numbers. I just wonder how we can trust IG's figures.

 

If nothing has changed except for the worst in two months, then its crystal clear that IG pays scant attention to the issue. Its simply not good enough and IG is really leading with its chin on this issue. They have had plenty of time to fix it. This issue has the potential to blow up the whole company if outside authorities start to ask questions. The answers will simply not be available. 

 

If a share broker treated their clients in this way, they would quickly be out of business.   

Share this post


Link to post
  • 0

Hi - please can you send the file itself to helpdesk@ig.com along with a quick overview of the issue you are having and someone will be able to look into this for you. As far as I know, no one else has  reported this so it would be something which requires further investigation. 

Share this post


Link to post
  • 0

Yeah, my running p&l aint showing proper figures either in my android app. Was doing so to start with, but after a week of so of demo account trading, it appears to have Frozen, even though individual trades in position panel are changing as they should.

Share this post


Link to post
  • 0

P&l is up and working again now. Don't know why it was out for a while. Thanks.

Share this post


Link to post

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
You are posting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×