Jump to content
  • 0

Forbidden error on all endpoints


Garry7

Question

Hi,

I'm getting an error whenever I try to log in via the API (I suspect all endpoints are affected cos it started happening on the 24th around 5.30pm UK time when I tried to retrieve current account balance)

The error is the following:
 

Quote

 

 Forbidden <HTML><HEAD>
<TITLE>Access Denied</TITLE>
</HEAD><BODY>

You don't have permission to access "http://demo-api.ig.com/gateway/deal/session" on this server.

 

Has anyone seen or overcome this error?

If I try logging in via the API companion, it works fine, seems like its just my server... I've tried via Python, curl and a basic Rest client in the browser, all having the same problem. Is it possible my server been blacklisted or something?

My live account is still logging in fine and running a live strategy, I was hoping to run a new strategy in demo mode for a month or so first but clearly that's not happening...

Link to comment

4 answers to this question

Recommended Posts

  • 0
4 hours ago, Garry7 said:

Hi,

I'm getting an error whenever I try to log in via the API (I suspect all endpoints are affected cos it started happening on the 24th around 5.30pm UK time when I tried to retrieve current account balance)

The error is the following:
 

Has anyone seen or overcome this error?

If I try logging in via the API companion, it works fine, seems like its just my server... I've tried via Python, curl and a basic Rest client in the browser, all having the same problem. Is it possible my server been blacklisted or something?

My live account is still logging in fine and running a live strategy, I was hoping to run a new strategy in demo mode for a month or so first but clearly that's not happening...

Hi @Garry7,

Thank you for your post.

You can to try logging into IG REST companion, which is a sample API (https://labs.ig.com/sample-apps/api-companion/index.html)

If you still facing issues, provide us with the username and API key, a screenshot of your attempt on REST would be helpful too. Send all the details to webapisupport@ig.com.

All the best - Arvin

Link to comment
  • 0

Hi @Garry7

I got exactly the same problem as you

It's driving me crazy that I could do nothing to fix this...

I was wondering if you had solved this problem? I mailed them but they only told me that the API key is available.

I do think that the live API service has blocked some server including mine or yours.

BTW, I use Google Apps Script.

Link to comment
  • 0
On 21/06/2022 at 10:19, BryanCheng said:

I've found that your problem is happened on Demo API but Live API is still working.

But to me it's opposite. I got problem on Live API but Demo API is still running well...

did u find any solutions?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • General Statistics

    • Total Topics
      20,053
    • Total Posts
      88,095
    • Total Members
      69,048
    • Most Online
      7,522
      10/06/21 10:53

    Newest Member
    GeoffAshG
    Joined 30/09/22 12:37
  • Posts

×
×
  • Create New...