Jump to content
  • 0

I can't open trading platform

Question

It only displays the IG logo in the center of the screen but won't open the trading platform when I click on "open platform".

ig.jpg

  • Like 1

Share this post


Link to post

Recommended Posts

  • 0
21 minutes ago, JohnMcClane said:

It only displays the IG logo in the center of the screen but won't open the trading platform when I click on "open platform".

not sure what's happening there. The web based platform opened for me earlier this morning and again just now with no problems.

Share this post


Link to post
  • 0

Hi I AGREE -  it does not open on new trading platform - but before selecting the IG open and look at old platform you can trade - looks like there is a problem there - as IG logo is not correct IMHO. 🙂 Tried calling tech support but no answer at present.

 

Share this post


Link to post
  • 0

I've been experiencing the same problem since trying to log in to trade a couple of hours ago.

I can log into the Dashboard but when I click to open the platform I get the same hung page with IG logo.

Share this post


Link to post
  • 0

I have an open trade running and I can't open trading platform. The new platform won't launch. Old platform wants me to verify my information and takes me around nowhere. I tried to launch prorealtime but it won't launch either. I don't know what to do.

Share this post


Link to post
  • 0
15 minutes ago, JohnMcClane said:

I have an open trade running and I can't open trading platform. The new platform won't launch. Old platform wants me to verify my information and takes me around nowhere. I tried to launch prorealtime but it won't launch either. I don't know what to do.

Hi these are all the services that will have access to your account.

https://status.ig.com

Have you tried the mobile app?

  • Sad 1

Share this post


Link to post
  • 0
31 minutes ago, jlz said:

Hi these are all the services that will have access to your account.

https://status.ig.com

Have you tried the mobile app?

Yes, it's "unavailable". IG is killing me today, they need to fix this.. 

 

igmobile.jpg

Share this post


Link to post
  • 0
Guest PipNick

I had the same problem - had to mark the site as safe with antivrus (bitdefender)

Share this post


Link to post
  • 0

Hi The account is functioning on Mobile APP John AND PROVIDING CORRECT UP TO DATE PRICES FOR US SHARES

I can verify this by my account on Hargreaves Lansdown

- but IG support not answering the phone at the time of post - most unusual.

V surprised not reported by anyone else.

  • Sad 1

Share this post


Link to post
  • 0
2 hours ago, David30b said:

Hi The account is functioning on Mobile APP John AND PROVIDING CORRECT UP TO DATE PRICES FOR US SHARES

I can verify this by my account on Hargreaves Lansdown

- but IG support not answering the phone at the time of post - most unusual.

V surprised not reported by anyone else.

Mobile now working for me too. I also managed to launch prorealtime but it won't show my open trades. Mobile does. I wonder why the trading platform on website isn't working though.

Share this post


Link to post
  • 0

Hi,

I'm having the same issue, I jget a logo when trying to access the trading platform.

 

Is this resolved for you?

 

Regards

Shawn

Share this post


Link to post
  • 0

Thanks.

I tried some of the settings but have had no luck.

I also tried three different browsers and currently I use a mac.

I will try and have a look to see if I can find anything.

 

Share this post


Link to post
  • 0
1 hour ago, Caseynotes said:

Hi, still no problem for me, take a look at some problem solving ideas on this page (for new platform about half way down)

https://www.ig.com/uk/help-and-support/charts/ig-charts/why-are-my-ig-charts-not-working?ref=FlashPDLeverage

Thanks, it helped. Looks like I have a Chrome problem and not an IG one as the new platform worked just fine on firefox just now. It's the chrome that needs fixing, thanks a lot.

Share this post


Link to post
  • 0
8 minutes ago, JohnMcClane said:

Thanks, it helped. Looks like I have a Chrome problem and not an IG one as the new platform worked just fine on firefox just now. It's the chrome that needs fixing, thanks a lot.

👍

speaking of browsers i see ms has downloaded edge on me, i was lead to believe it was lighter and quicker than chrome but i'm not seeing it, anyone else tried it?

Share this post


Link to post
  • 0

Hi All,

My issue has been resolved.

I have been using Firefox all along, I use bitdefender for anti-virus and I have anti-tracker enabled. I allowed https://deal.ig.com/wtp/  in my anti-tracker settings and it is now working fine.

 

Share this post


Link to post
  • 0

I'm still having this same issue on Chrome and Firefox. I've tried clearing the browser cache and still no good. After opening the platform it just shows the IG logo on this page https://deal.ig.com/wtp/

Has been working fine previously so there must have been an update in the last couple of days. Any other ideas?

Share this post


Link to post
  • 0
4 hours ago, JohnMcClane said:

https://deal.ig.com/wtp/ still won't open for me. - FIX WITH MICROSOFT EDGE USE

I got to speak to helpdesk for 45 mins yesterday 

 and IT IS a chrome issue - they will fix it later but - as now using Microsoft Edge with FULL capacity - suggest to use this as has excellent reviews as a substitute for chrome - may well do myself.

Regards

David

  • Thanks 1

Share this post


Link to post
  • 0
10 minutes ago, David30b said:

I got to speak to helpdesk for 45 mins yesterday 

 and IT IS a chrome issue - they will fix it later but - as now using Microsoft Edge with FULL capacity - suggest to use this as has excellent reviews as a substitute for chrome - may well do myself.

Regards

David

what does 'full capacity' mean, someone told me there was an 'Edge Chromium' but when I looked on the MS web site it said I already had Edge but it didn't seem any faster to me playing around for a day?

Share this post


Link to post
  • 0
3 hours ago, Caseynotes said:

👍

speaking of browsers i see ms has downloaded edge on me, i was lead to believe it was lighter and quicker than chrome but i'm not seeing it, anyone else tried it?

It's got the same underlying engine as Chrome and yet strangely it doesn't perform as well for me as Chrome does.  Firefox is worst of all (possibly because it blocks all the cr@p that wants to track your every movement)

  • Thanks 1

Share this post


Link to post
  • 0
4 hours ago, Caseynotes said:

👍

speaking of browsers i see ms has downloaded edge on me, i was lead to believe it was lighter and quicker than chrome but i'm not seeing it, anyone else tried it?

Hi briefly trying Edge out out and looked ok - but only to solve my immediate problem - have Edge on one screen and Chrome on the second and works fine - will have to look at the set up to fix of chrome going forward

Share this post


Link to post
  • 0

I haven't had any problems using Chrome.

Share this post


Link to post
  • 0
20 minutes ago, dmedin said:

I haven't had any problems using Chrome.

Hi,

 

It is something to do with my settings in Chrome causing the problem - will fix later - have a work around at present by using Microsoft Edge (new version from 2020 which IS superior to old one supposedly)

  • Like 1

Share this post


Link to post
  • 0
Guest TECHRADAR - Review on Edge
8 hours ago, Caseynotes said:

👍

speaking of browsers i see ms has downloaded edge on me, i was lead to believe it was lighter and quicker than chrome but i'm not seeing it, anyone else tried it?

Yes Looks good had excellent review on TECHRADAR - rated better than chrome

Share this post


Link to post
  • 0

I had the same IG logo screen and problem too.

But works fine if I use Edge. 

I noticed the problem with Chrome came soon after I rejected a strong recommendation by Microsoft to adopt Edge as the default web browser. Maybe Microsoft has somehow interfered with the Chrome but I have no proof to back it up.

Share this post


Link to post
  • 0
Guest oliverwarbucks
On 06/07/2020 at 09:43, JohnMcClane said:

It only displays the IG logo in the center of the screen but won't open the trading platform when I click on "open platform".

Same here on Wednesday 8th July. The problem is still unresolved. I tried clearing the cache - did not solve.

Quote

ig.jpg

 

Share this post


Link to post
  • 0

It will work in Chrome if you use an incognito window or use Edge.

Share this post


Link to post
  • 0

Hi @David30b @dmedin @Caseynotes,

We found that it was a problem for all users who have BitDefender installed, it creates extensions in certain browsers such as Chrome, Firefox and Safari which then blocks the New Web Trading Platform from loading up. The easiest way to get around it when using chrome is to type chrome://extensions/ in the URL field, then disable the BitDefender extensions. 

Our developers are working on a permanent solution as it may happen after every BitDefender update. 

Hope that helps.

Anton

  • Thanks 1

Share this post


Link to post
  • 0
On 07/07/2020 at 20:41, Guest TECHRADAR - Review on Edge said:

Yes Looks good had excellent review on TECHRADAR - rated better than chrome

yes that's what I'd heard too but having spent a couple of hours with it I was left with the impression it was slower than chrome.

Share this post


Link to post

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
You are posting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Member Statistics

    • Total Topics
      12,760
    • Total Posts
      65,537
    • Total Members
      86,292
    Newest Member
    Han7
    Joined 22/10/20 08:46
  • Posts

    • EWP does NOT work  - They've been calling for a top and decline to near 0 since 1986!!!!! Certain things in EWP do work though and can be used to profit from the markets Again there's a massive myth about Fib Rets and Ext's - sometimes they work, often they don't, that in itself tells you something is amiss - but again they can be used to profit from the markets I would look at the 50% ret level which is not a fib level, its a gann level - Hence why the market came to a smack bang stop around that level in the 1960's, 70's, 2003 and 2009 If all you ever did was trade Elliott Wave 2's which are in fact Gann's Secondary reactions (gann wrote about them 1st) you do rather well
    • well done - still short?  now in important zone..?  strong moves in either direction likely..?  back to pure Corona play..?
    • As our very old friend WD Gann said "4th Time at a level and it often goes through" Same with the FTSE100 Index yesterday - bingo
×
×